Roundup: Permission bypass — GLSA 200805-21

A vulnerability in Roundup allows for bypassing permission restrictions.

Affected Packages

www-apps/roundup on all architectures
Affected versions < 1.4.4-r1
Unaffected versions >= 1.4.4-r1

Background

Roundup is an issue-tracking system with command-line, web and e-mail interfaces.

Description

Philipp Gortan reported that the xml-rpc server in Roundup does not check property permissions (CVE-2008-1475). Furthermore, Roland Meister discovered multiple vulnerabilities caused by unspecified errors, some of which may be related to cross-site scripting (CVE-2008-1474).

Impact

A remote attacker could possibly exploit the first vulnerability to edit or view restricted properties via the list(), display(), and set() methods. The impact and attack vectors of the second vulnerability are unknown.

Workaround

There is no known workaround at this time.

Resolution

All Roundup users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/roundup-1.4.4-r1"

References

Release Date
May 27, 2008

Latest Revision
May 27, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries