Pan: User-assisted execution of arbitrary code — GLSA 200807-15

A buffer overflow vulnerability in Pan may allow remote attacker to execute arbitrary code.

Affected Packages

net-nntp/pan on all architectures
Affected versions < 0.132-r3
Unaffected versions >= 0.132-r3
revision >= 0.14.2.91-r2
= 0.14.2

Background

Pan is a newsreader for the GNOME desktop.

Description

Pavel Polischouk reported a boundary error in the PartsBatch class when processing .nzb files.

Impact

A remote attacker could entice a user to open a specially crafted .nzb file, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Pan users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-nntp/pan-0.132-r3"

References

Release Date
July 31, 2008

Latest Revision
July 31, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries