HAVP: Denial of Service — GLSA 200809-11

A Denial of Service vulnerability has been reported in HAVP.

Affected Packages

net-proxy/havp on all architectures
Affected versions < 0.89
Unaffected versions >= 0.89

Background

HAVP is a HTTP AntiVirus Proxy.

Description

Peter Warasin reported an infinite loop in sockethandler.cpp when connecting to a non-responsive HTTP server.

Impact

A remote attacker could send requests to unavailable servers, resulting in a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All HAVP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-proxy/havp-0.89"

References

Release Date
September 21, 2008

Latest Revision
September 21, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries