Avahi: Denial of Service — GLSA 200901-11

A Denial of Service vulnerability has been discovered in Avahi.

Affected Packages

net-dns/avahi on all architectures
Affected versions < 0.6.24
Unaffected versions >= 0.6.24

Background

Avahi is a system that facilitates service discovery on a local network.

Description

Hugo Dias reported a failed assertion in the originates_from_local_legacy_unicast_socket() function in avahi-core/server.c when processing mDNS packets with a source port of 0.

Impact

A remote attacker could send specially crafted packets to the daemon, leading to its crash.

Workaround

There is no known workaround at this time.

Resolution

All Avahi users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dns/avahi-0.6.24"

References

Release Date
January 14, 2009

Latest Revision
January 14, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries