DevIL: User-assisted execution of arbitrary code — GLSA 200903-04

Multiple boundary errors in DevIL may allow for the execution of arbitrary code.

Affected Packages

media-libs/devil on all architectures
Affected versions < 1.7.7
Unaffected versions >= 1.7.7

Background

Developer's Image Library (DevIL) is a cross-platform image library.

Description

Stefan Cornelius (Secunia Research) discovered two boundary errors within the iGetHdrHeader() function in src-IL/src/il_hdr.c.

Impact

A remote attacker could entice a user to open a specially crafted Radiance RGBE file, possibly resulting in the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All DevIL users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/devil-1.7.7"

References

Release Date
March 06, 2009

Latest Revision
March 06, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries