An integer overflow vulnerability in wxGTK might enable remote attackers to cause the execution of arbitrary code.
|Package||x11-libs/wxGTK on all architectures|
|Affected versions||< 22.214.171.124-r1|
|Unaffected versions||revision >= 126.96.36.199-r5
wxGTK is the GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit.
wxGTK is prone to an integer overflow error in the wxImage::Create() function in src/common/image.cpp, possibly leading to a heap-based buffer overflow.
A remote attacker might entice a user to open a specially crafted JPEG file using a program that uses wxGTK, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
There is no known workaround at this time.
All wxGTK 2.6 users should upgrade to an updated version:
# emerge --sync # emerge --ask --oneshot --verbose ">=x11-libs/wxGTK-188.8.131.52-r5"
All wxGTK 2.8 users should upgrade to an updated version:
# emerge --sync # emerge --ask --oneshot --verbose ">=x11-libs/wxGTK-184.108.40.206-r1"
NOTE: This is a legacy GLSA. Updates for all affected architectures are available since August 9, 2009. It is likely that your system is already no longer affected by this issue.
September 02, 2010
September 02, 2010: 01