FreeRADIUS: Multiple vulnerabilities — GLSA 201311-09

Multiple vulnerabilities have been found in FreeRADIUS, the worst of which allow execution of arbitrary code or Denial of Service.

Affected Packages

net-dialup/freeradius on all architectures
Affected versions < 2.2.0
Unaffected versions >= 2.2.0

Background

FreeRADIUS is an open source RADIUS authentication server.

Description

Multiple vulnerabilities have been discovered in FreeRADIUS. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All FreeRADIUS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dialup/freeradius-2.2.0"
 

References

Release Date
November 13, 2013

Latest Revision
November 13, 2013: 1

Severity
high

Exploitable
remote

Bugzilla entries