Perl: Multiple vulnerabilities — GLSA 201311-17

Multiple vulnerabilities were found in Perl, the worst of which could allow a local attacker to cause a Denial of Service condition.

Affected Packages

dev-lang/perl on all architectures
Affected versions < 5.12.3-r1
Unaffected versions >= 5.12.3-r1

Background

Perl is Larry Wall’s Practical Extraction and Report Language.

Description

Multiple vulnerabilities have been discovered in Perl. Please review the CVE identifiers referenced below for details.

Impact

A local attacker could cause a Denial of Service condition or perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application. A context-dependent attacker could cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Perl users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/perl-5.12.3-r1"
 

References

Release Date
November 28, 2013

Latest Revision
November 28, 2013: 1

Severity
high

Exploitable
local, remote

Bugzilla entries