Libgdiplus: Arbitrary code execution — GLSA 201401-01

Multiple integer overflow vulnerabilities in Libgdiplus may allow remote attackers to execute arbitrary code.

Affected Packages

dev-dotnet/libgdiplus on all architectures
Affected versions < 2.6.7-r1
Unaffected versions >= 2.6.7-r1

Background

Libgdiplus is the Mono library that provide a GDI+ comptible API on non-Windows operating systems.

Description

An integer overflow flaw has been discovered in Libgdiplus.

Impact

A remote attacker could entice a user to open a specially-crafted TIFF/JPEG/BMP file, potentially resulting in arbitrary code execution.

Workaround

There is no known workaround at this time.

Resolution

All Libgdiplus users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-dotnet/libgdiplus-2.6.7-r1"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since September 12, 2010. It is likely that your system is already no longer affected by this issue.

References

Release Date
January 05, 2014

Latest Revision
January 05, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries