Multiple vulnerabilities have been found in Asterisk, the worst of which may allow execution of arbitrary code.
|Package||net-misc/asterisk on all architectures|
|Affected versions||< 11.7.0|
|Unaffected versions||>= 11.7.0
revision >= 126.96.36.199
Asterisk is an open source telephony engine and toolkit.
Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers referenced below for details.
A remote attacker could execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or obtain sensitive information.
There is no known workaround at this time.
All Asterisk 11.* users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.7.0"
All Asterisk 1.8.* users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/asterisk-188.8.131.52"