Asterisk: Multiple vulnerabilities — GLSA 201401-15

Multiple vulnerabilities have been found in Asterisk, the worst of which may allow execution of arbitrary code.

Affected Packages

net-misc/asterisk on all architectures
Affected versions < 11.7.0
Unaffected versions >= 11.7.0
revision >= 1.8.25.0

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or obtain sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All Asterisk 11.* users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.7.0"
 

All Asterisk 1.8.* users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.25.0"
 

References

Release Date
January 21, 2014

Latest Revision
January 21, 2014: 1

Severity
high

Exploitable
remote

Bugzilla entries