Roundcube: Arbitrary code execution — GLSA 201402-15

A vulnerability in Roundcube could result in arbitrary code execution, SQL injection, or reading of arbitrary files.

Affected Packages

mail-client/roundcube on all architectures
Affected versions < 0.9.5
Unaffected versions >= 0.9.5
revision >= 0.8.7

Background

Roundcube is a browser-based multilingual IMAP client with an application-like user interface.

Description

A vulnerability in steps/utils/save_pref.inc allows remote attackers to use the _session parameter to change configuration settings.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, inject SQL code, or read arbitrary files.

Workaround

There is no known workaround at this time.

Resolution

All Roundcube 0.9 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/roundcube-0.9.5"
 

All Roundcube 0.8 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/roundcube-0.8.7"
 

References

Release Date
February 11, 2014

Latest Revision
February 11, 2014: 1

Severity
high

Exploitable
remote

Bugzilla entries