GnuPG, Libgcrypt: Multiple vulnerabilities — GLSA 201402-24

Multiple vulnerabilities have been discovered in GnuPG and Libgcrypt, which may result in execution of arbitrary code, Denial of Service, or the disclosure of private keys.

Affected Packages

app-crypt/gnupg on all architectures
Affected versions < 2.0.22
Unaffected versions >= 2.0.22
revision >= 1.4.16
revision >= 1.4.17
revision >= 1.4.18
revision >= 1.4.19
revision >= 1.4.20
revision >= 1.4.21
dev-libs/libgcrypt on all architectures
Affected versions < 1.5.3
Unaffected versions >= 1.5.3

Background

The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of cryptographic software. Libgcrypt is a cryptographic library based on GnuPG.

Description

Multiple vulnerabilities have been discovered in GnuPG and Libgcrypt. Please review the CVE identifiers referenced below for details.

Impact

An unauthenticated remote attacker may be able to execute arbitrary code with the privileges of the user running GnuPG, cause a Denial of Service condition, or bypass security restrictions. Additionally, a side-channel attack may allow a local attacker to recover a private key, please review “Flush+Reload: a High Resolution, Low Noise, L3 Cache Side-Channel Attack” in the References section for further details.

Workaround

There is no known workaround at this time.

Resolution

All GnuPG 2.0 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-2.0.22"
 

All GnuPG 1.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-1.4.16"
 

All Libgcrypt users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libgcrypt-1.5.3"
 

References

Release Date
February 21, 2014

Latest Revision
August 24, 2016: 3

Severity
normal

Exploitable
local, remote

Bugzilla entries