Multiple vulnerabilities have been discovered in GnuTLS, the worst of which could lead to arbitrary code execution.
|Package||net-libs/gnutls on all architectures|
|Affected versions||< 2.12.23-r6|
|Unaffected versions||>= 2.12.23-r6|
GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.
Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.
A remote attacker could utilize multiple vectors to spoof arbitrary SSL servers via a crafted certificate, execute arbitrary code or cause a Denial of Service condition.
There is no known workaround at this time.
All GnuTLS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r6"