RSYSLOG: Denial of Service — GLSA 201412-35

Multiple vulnerabilities have been found in RSYSLOG, allowing attackers to cause Denial of Service.

Affected Packages

app-admin/rsyslog on all architectures
Affected versions < 8.4.2
Unaffected versions >= 8.4.2

Background

RSYSLOG is an enhanced multi-threaded syslogd with database support and more.

Description

Multiple vulnerabilities have been discovered in RSYSLOG. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker may be able to create a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All RSYSLOG users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/rsyslog-8.4.2"
 

References

Release Date
December 24, 2014

Latest Revision
December 24, 2014: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries