Multiple vulnerabilities have been discovered in PHP, the worst of which could lead to remote execution of arbitrary code.
|Package||dev-lang/php on all architectures|
|Affected versions||< 5.5.21|
|Unaffected versions||>= 5.5.21
revision >= 5.4.37
revision >= 5.4.38
revision >= 5.4.39
revision >= 5.4.40
revision >= 5.4.41
revision >= 5.4.42
revision >= 5.4.43
revision >= 5.4.44
revision >= 5.4.45
PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.
Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.
A remote attacker can leverage these vulnerabilities to execute arbitrary code or cause Denial of Service.
There is no known workaround at this time.
All PHP 5.5 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.21"
All PHP 5.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.37"
All PHP 5.3 users should upgrade to the latest version. This branch is currently past the end of life and it will no longer receive security fixes. All PHP 5.3 users are strongly recommended to upgrade to the current stable version of PHP 5.5 or previous stable version of PHP 5.4, which are supported till at least 2016 and 2015 respectively.