file: Denial of Service — GLSA 201503-08

Vulnerabilities in file could allow a context-dependent attack to create a Denial of Service condition.

Affected Packages

sys-apps/file on all architectures
Affected versions < 5.22
Unaffected versions >= 5.22

Background

The file utility attempts to identify a file’s format by scanning binary data for patterns.

Description

Multiple issues with the ELF parser used by the file utility have been detected and fixed.

Impact

A context-dependent attacker can cause Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All file users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-apps/file-5.22"
 

References

Release Date
March 16, 2015

Latest Revision
March 16, 2015: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries