phpMyAdmin: Multiple vulnerabilities — GLSA 201505-03

Multiple vulnerabilities have been found in phpMyAdmin, the worst of which could lead to arbitrary code execution.

Affected Packages

dev-db/phpmyadmin on all architectures
Affected versions < 4.2.13
Unaffected versions >= 4.2.13
revision >= 4.1.14.7
revision >= 4.0.10.6
revision >= 4.0.10.15
revision >= 4.0.10.16
revision >= 4.0.10.17
revision >= 4.0.10.18

Background

phpMyAdmin is a web-based management tool for MySQL databases.

Description

Multiple vulnerabilities have been discovered in phpMyAdmin. Please review the CVE identifiers referenced below for details.

Impact

A remote authenticated attacker could exploit these vulnerabilities to include and execute arbitrary local files via a crafted parameter, inject SQL code, or to conduct Cross-Site Scripting attacks.

Workaround

There is no known workaround at this time.

Resolution

All phpMyAdmin 4.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-4.2.13"
 

All phpMyAdmin 4.1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-4.1.14.7"
 

All phpMyAdmin 4.0 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-4.0.10.6"
 

References

Release Date
May 31, 2015

Latest Revision
May 14, 2016: 2

Severity
low

Exploitable
remote

Bugzilla entries