libXfont: Multiple vulnerabilities — GLSA 201507-21

Multiple vulnerabilities have been found in libXfont, the worst of which could result in execution of arbitrary code or Denial of Service.

Affected Packages

x11-libs/libXfont on all architectures
Affected versions < 1.5.1
Unaffected versions revision >= 1.4.9
>= 1.5.1

Background

libXfont is an X11 font rasterisation library.

Description

Multiple vulnerabilities have been discovered in libXfont. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libXfont 1.4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/libXfont-1.4.9"
 

All libXfont 1.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/libXfont-1.5.1"
 

References

Release Date
July 22, 2015

Latest Revision
July 22, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries