cURL: Multiple vulnerabilities — GLSA 201509-02

Multiple vulnerabilities have been found in cURL, the worst of which can allow remote attackers to cause Denial of Service condition.

Affected Packages

net-misc/curl on all architectures
Affected versions < 7.43.0
Unaffected versions >= 7.43.0

Background

cURL is a tool and libcurl is a library for transferring data with URL syntax.

Description

Multiple vulnerabilities have been discovered in cURL. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly obtain sensitive information, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All cURL users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/curl-7.43.0"
 

References

Release Date
September 24, 2015

Latest Revision
September 24, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries