Git: Arbitrary command execution — GLSA 201509-06

An attacker could execute arbitrary commands via Git repositories in a case-insensitive or case-normalizing filesystem.

Affected Packages

dev-vcs/git on all architectures
Affected versions < 2.0.5
Unaffected versions revision >= 1.8.5.6
revision >= 1.9.5
>= 2.0.5

Background

Git is a free and open source distributed version control system designed to handle everything from small to very large projects with speed and efficiency.

Description

A vulnerability in Git causing Git-compatible clients that access case-insensitive or case-normalizing filesystems to overwrite the .git/config when cloning or checking out a repository, leading to execution of arbitrary commands.

Impact

An attacker can execute arbitrary commands on a client machine that clones a crafted malicious Git tree.

Workaround

There is no known workaround at this time.

Resolution

All Git 1.8.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-vcs/git-1.8.5.6"
 

All Git 1.9.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-vcs/git-1.9.5"
 

All Git 2.0.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.0.5"
 

References

Release Date
September 24, 2015

Latest Revision
September 24, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries