MediaWiki: Multiple vulnerabilities — GLSA 201510-05

Multiple vulnerabilities have been found in MediaWiki, the worst of which may allow remote attackers to cause a Denial of Service.

Affected Packages

www-apps/mediawiki on all architectures
Affected versions < 1.25.2
Unaffected versions >= 1.25.2
revision >= 1.24.3
revision >= 1.23.10

Background

MediaWiki is a collaborative editing software used by large projects such as Wikipedia.

Description

Multiple vulnerabilities have been discovered in MediaWiki. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker may be able to create a Denial of Service condition, obtain sensitive information, bypass security restrictions, and inject arbitrary web script or HTML.

Workaround

There is no known workaround at this time.

Resolution

All MediaWiki 1.25 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.25.2"
 

All MediaWiki 1.24 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.24.3"
 

All MediaWiki 1.23 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.23.10"
 

References

Release Date
October 31, 2015

Latest Revision
October 31, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries