MPFR: User-assisted execution of arbitrary code — GLSA 201512-06

A buffer overflow vulnerability in MPFR could allow remote attackers to execute arbitrary code or cause Denial of Service.

Affected Packages

dev-libs/mpfr on all architectures
Affected versions < 3.1.3_p4
Unaffected versions >= 3.1.3_p4

Background

MPFR is a library for multiple-precision floating-point computations with exact rounding.

Description

MPFR fails to adequately check user-supplied input, which could lead to a buffer overflow.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All MPFR users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/mpfr-3.1.3_p4"
 

References

Release Date
December 30, 2015

Latest Revision
December 30, 2015: 1

Severity
normal

Exploitable
remote

Bugzilla entries