OpenSMTPD: Multiple vulnerabilities — GLSA 201601-04

Multiple vulnerabilities have been found in OpenSMTPD, the worst allowing remote attackers to execute arbitrary code.

Affected Packages

mail-mta/opensmtpd on all architectures
Affected versions < 5.7.3_p1
Unaffected versions >= 5.7.3_p1

Background

OpenSMTPD is a lightweight but featured SMTP daemon from OpenBSD.

Description

Multiple vulnerabilities have been discovered in OpenSMTPD. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All OpenSMTPD users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/opensmtpd-5.7.3_p1"
 

References

Release Date
January 27, 2016

Latest Revision
January 27, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries