GnuPG: Multiple vulnerabilities — GLSA 201606-04

Multiple vulnerabilities have been found in GnuPG and libgcrypt, the worst of which may allow a local attacker to obtain confidential key information.

Affected Packages

app-crypt/gnupg on all architectures
Affected versions < 2.0.26-r3
Unaffected versions >= 2.0.26-r3
revision >= 1.4.19
revision >= 1.4.20
revision >= 1.4.21
revision >= 1.4.22
dev-libs/libgcrypt on all architectures
Affected versions < 1.6.3-r4
Unaffected versions >= 1.6.3-r4

Background

The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of cryptographic software.

Description

Multiple vulnerabilities have been discovered in GnuPG and libgcrypt, please review the CVE identifiers referenced below for details.

Impact

A local attacker could possibly cause a Denial of Service condition. Side-channel attacks could be leveraged to obtain key material.

Workaround

There is no known workaround at this time.

Resolution

All GnuPG 2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-2.0.26-r3"
 

All GnuPG 1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-1.4.19"
 

All libgcrypt users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libgcrypt-1.6.3-r4"
 

References

Release Date
June 05, 2016

Latest Revision
June 10, 2016: 2

Severity
normal

Exploitable
local, remote

Bugzilla entries