Ansible: Privilege escalation — GLSA 201607-14

A vulnerability in Ansible may allow local attackers to gain escalated privileges or write arbitrary files.

Affected Packages

app-admin/ansible on all architectures
Affected versions < 2.0.2.0-r1
Unaffected versions >= 2.0.2.0-r1
revision >= 1.9.6

Background

Ansible is a radically simple IT automation platform.

Description

The create_script function in the lxc_container module of Ansible uses predictable temporary file names, making it vulnerable to a symlink attack.

Impact

Local attackers could write arbitrary files or gain escalated privileges within the container.

Workaround

There is no known workaround at this time.

Resolution

All Ansible 1.9.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/ansible-1.9.6"
 

All Ansible 2.0.2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/ansible-2.0.2.0-r1"
 

References

Release Date
July 20, 2016

Latest Revision
July 20, 2016: 2

Severity
normal

Exploitable
local

Bugzilla entries