Adobe Flash Player: Multiple vulnerabilities — GLSA 201610-10

Multiple vulnerabilities have been found in Adobe Flash Player, the worst of which allows remote attackers to execute arbitrary code.

Affected Packages

www-plugins/adobe-flash on all architectures
Affected versions < 23.0.0.205
Unaffected versions >= 23.0.0.205
revision >= 11.2.202.635
revision >= 11.2.202.643
revision >= 11.2.202.644

Background

The Adobe Flash Player is a renderer for the SWF file format, which is commonly used to provide interactive websites.

Description

Multiple vulnerabilities have been discovered in Adobe Flash Player. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, obtain sensitive information, or bypass security restrictions.

Workaround

There is no known workaround at this time.

Resolution

All Adobe Flash Player 23.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=www-plugins/adobe-flash-23.0.0.205"
 

All Adobe Flash Player 11.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=www-plugins/adobe-flash-11.2.202.635"
 

References

Release Date
October 29, 2016

Latest Revision
November 01, 2016: 2

Severity
normal

Exploitable
remote

Bugzilla entries