Xen: Multiple vulnerabilities — GLSA 201611-09

Multiple vulnerabilities have been found in Xen, the worst of which allows gaining of privileges on the host system.

Affected Packages

app-emulation/xen on all architectures
Affected versions < 4.6.3-r3
Unaffected versions >= 4.6.3-r3
app-emulation/xen-tools on all architectures
Affected versions < 4.6.3-r2
Unaffected versions >= 4.6.3-r2

Background

Xen is a bare-metal hypervisor.

Description

Multiple vulnerabilities have been discovered in Xen. Please review the CVE identifiers referenced below for details.

Impact

A malicious guest administrator could escalate their privileges on the host system or cause a Denial of Service. Additionally, a malicious unprivileged guest user may be able to obtain or corrupt sensitive information (including cryptographic material) in other programs in the same guest.

Workaround

There is no known workaround at this time.

Resolution

All Xen users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-4.6.3-r3"
 

All Xen tools users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-tools-4.6.3-r2
 

References

Release Date
November 15, 2016

Latest Revision
November 15, 2016: 1

Severity
normal

Exploitable
remote

Bugzilla entries