RPCBind: Denial of Service — GLSA 201611-17

A buffer overflow in RPCBind might allow remote attackers to cause a Denial of Service.

Affected Packages

net-nds/rpcbind on all architectures
Affected versions < 0.2.3-r1
Unaffected versions >= 0.2.3-r1

Background

The RPCBind utility is a server that converts RPC program numbers into universal addresses.

Description

A use-after-free vulnerability was discovered in RPCBind’s svc_dodestroy function when trying to free a corrupted xprt->xp_netid pointer.

Impact

A remote attacker could possibly cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All RPCBind users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-nds/rpcbind-0.2.3-r1"
 

References

Release Date
November 22, 2016

Latest Revision
November 22, 2016: 2

Severity
normal

Exploitable
remote

Bugzilla entries