Bash: Multiple vulnerabilities — GLSA 201701-02

Multiple vulnerabilities were found in Bash, the worst of which may allow execution of arbitrary code.

Affected Packages

app-shells/bash on all architectures
Affected versions < 4.3_p48-r1
Unaffected versions >= 4.3_p48-r1

Background

Bash is the standard GNU Bourne Again SHell.

Description

Multiple vulnerabilities have been discovered in Bash. Please review the CVE identifiers referenced below for details.

Impact

A local attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Bash users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-shells/bash-4.3_p48-r1"
 

References

Release Date
January 01, 2017

Latest Revision
January 01, 2017: 1

Severity
normal

Exploitable
local

Bugzilla entries