Xdg-Utils: Command injection — GLSA 201701-09

A command injection vulnerability in Xdg-Utils may allow for the execution of arbitrary code.

Affected Packages

x11-misc/xdg-utils on all architectures
Affected versions < 1.1.1
Unaffected versions >= 1.1.1

Background

Xdg-Utils is a set of tools allowing all applications to easily integrate with the Free Desktop configuration.

Description

An eval injection vulnerability was discovered in Xdg-Utils.

Impact

A context-dependent attacker could execute arbitrary code via the URL argument to xdg-open.

Workaround

There is no known workaround at this time.

Resolution

All Xdg-Utils users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-misc/xdg-utils-1.1.1"
 

References

Release Date
January 01, 2017

Latest Revision
January 01, 2017: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries