Python: Multiple vulnerabilities — GLSA 201701-18

Multiple vulnerabilities have been found in Python, the worst of which could lead to arbitrary code execution.

Affected Packages

dev-lang/python on all architectures
Affected versions < 3.4.5
Unaffected versions >= 2.7.12
>= 3.4.5

Background

Python is an interpreted, interactive, object-oriented programming language.

Description

Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted index file using Python’s dumbdbm module, possibly resulting in execution of arbitrary code with the privileges of the process.

A remote attacker could entice a user to process a specially crafted input stream using Python’s zipimporter module, possibly allowing attackers to cause unspecified impact.

A man in the middle attacker could strip out the STARTTLS command without generating an exception on the Python SMTP client application, preventing the establishment of the TLS layer.

Workaround

There is no known workaround at this time.

Resolution

All Python 2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.12:2.7"
 

All Python 3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-3.4.5:3.4"
 

References

Release Date
January 10, 2017

Latest Revision
February 24, 2017: 2

Severity
normal

Exploitable
remote

Bugzilla entries