7-Zip: Multiple vulnerabilities — GLSA 201701-27

Multiple vulnerabilities have been found in 7-Zip, the worst of which may allow execution of arbitrary code.

Affected Packages

app-arch/p7zip on all architectures
Affected versions < 16.02-r1
Unaffected versions >= 16.02-r1

Background

7-Zip is an open-source file archiver, an application used primarily to compress files. 7-Zip uses its own 7z archive format, but can read and write several other archive formats.

Description

Multiple vulnerabilities have been discovered in 7-Zip. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted archive file possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All 7-Zip users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-arch/p7zip-16.02-r1"
 

References

Release Date
January 11, 2017

Latest Revision
January 11, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries