PostgreSQL: Multiple vulnerabilities — GLSA 201701-33

Multiple vulnerabilities have been found in PostgreSQL, the worst of which could result in execution of arbitrary code or privilege escalation.

Affected Packages

dev-db/postgresql on all architectures
Affected versions < 9.5.4
Unaffected versions >= 9.5.4
>= 9.4.9
>= 9.3.14
>= 9.2.18
>= 9.1.23

Background

PostgreSQL is an open source object-relational database management system.

Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or escalate privileges.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.4:9.5"
 

All PostgreSQL 9.4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">dev-db/postgresql-9.4.9:9.4"
 

All PostgreSQL 9.3.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">dev-db/postgresql-9.3.14:9.3"
 

All PostgreSQL 9.2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">dev-db/postgresql-9.2.18:9.2"
 

All PostgreSQL 9.1.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">dev-db/postgresql-9.1.23:9.1"
 

References

Release Date
January 12, 2017

Latest Revision
January 12, 2017: 4

Severity
normal

Exploitable
remote

Bugzilla entries