Quagga: Multiple vulnerabilities — GLSA 201701-48

Multiple vulnerabilities have been found in Quagga, the worst of which could allow remote attackers to execute arbitrary code.

Affected Packages

net-misc/quagga on all architectures
Affected versions < 1.1.0-r2
Unaffected versions >= 1.1.0-r2

Background

Quagga is a free routing daemon replacing Zebra supporting RIP, OSPF and BGP.

Description

Multiple vulnerabilities have been discovered in Quagga. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could send a specially crafted packet possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Quagga users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/quagga-1.1.0-r2"
 

References

Release Date
January 21, 2017

Latest Revision
January 21, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries