GNU C Library: Multiple vulnerabilities — GLSA 201702-11

Multiple vulnerabilities have been found in the GNU C Library, the worst of which allows context-dependent attackers to execute arbitrary code.

Affected Packages

sys-libs/glibc on all architectures
Affected versions < 2.23-r3
Unaffected versions >= 2.23-r3

Background

The GNU C library is the standard C library used by Gentoo Linux systems.

Description

Multiple vulnerabilities have been discovered in the GNU C Library. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker could possibly execute arbitrary code with the privileges of the process, disclose sensitive information, or cause a Denial of Service condition via multiple vectors.

Workaround

There is no known workaround at this time.

Resolution

All GNU C Library users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-libs/glibc-2.23-r3"
 

References

Release Date
February 19, 2017

Latest Revision
February 19, 2017: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries