minicom: Remote execution of arbitrary code — GLSA 201706-13

An out-of-bounds data access in minicom might allow remote attackers to execute arbitrary code.

Affected Packages

net-dialup/minicom on all architectures
Affected versions < 2.7.1
Unaffected versions >= 2.7.1

Background

Minicom is a text-based serial port communications program.

Description

In minicom before version 2.7.1, the escparms[] buffer in vt100.c is vulnerable to an overflow.

Impact

A remote attacker, able to connect to a minicom port, could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All minicom users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dialup/minicom-2.7.1"
 

References

Release Date
June 06, 2017

Latest Revision
June 06, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries