FreeType: Multiple vulnerabilities — GLSA 201706-14

Multiple vulnerabilities have been found in FreeType, the worst of which allows remote attackers to execute arbitrary code.

Affected Packages

media-libs/freetype on all architectures
Affected versions < 2.8
Unaffected versions >= 2.8

Background

FreeType is a high-quality and portable font engine.

Description

Multiple vulnerabilities have been discovered in FreeType. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to use a specially crafted font file using FreeType, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All FreeType users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/freetype-2.8"
 

References

Release Date
June 06, 2017

Latest Revision
June 06, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries