PostgreSQL: Multiple vulnerabilities — GLSA 201710-06

Multiple vulnerabilities have been found in PostgreSQL, the worst of which could result in privilege escalation.

Affected Packages

dev-db/postgresql on all architectures
Affected versions < 9.6.4
Unaffected versions >= 9.6.4
>= 9.5.8
>= 9.4.13
>= 9.3.18
>= 9.2.22

Background

PostgreSQL is an open source object-relational database management system.

Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please review the referenced CVE identifiers for details.

Impact

A remote attacker could escalate privileges, cause a Denial of Service condition, obtain passwords, cause a loss in information, or obtain sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.4"
 

All PostgreSQL 9.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.8"
 

All PostgreSQL 9.4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.4.13"
 

All PostgreSQL 9.3.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.3.18"
 

All PostgreSQL 9.2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.2.22"
 

References

Release Date
October 08, 2017

Latest Revision
October 08, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries