GNU Libtasn1: Multiple vulnerabilities — GLSA 201710-11

Multiple vulnerabilities have been found in GNU Libtasn1, the worst of which may allow remote attackers to execute arbitrary code.

Affected Packages

dev-libs/libtasn1 on all architectures
Affected versions < 4.12-r1
Unaffected versions >= 4.12-r1

Background

A library that provides Abstract Syntax Notation One (ASN.1, as specified by the X.680 ITU-T recommendation) parsing and structures management, and Distinguished Encoding Rules (DER, as per X.690) encoding and decoding functions.

Description

Multiple vulnerabilities have been discovered in GNU Libtasn1. Please review the referenced CVE identifiers for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or have other unspecified impacts.

Workaround

There is no known workaround at this time.

Resolution

All GNU Libtasn1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libtasn1-4.12-r1"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

References

Release Date
October 13, 2017

Latest Revision
October 13, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries