Puppet Agent: Multiple vulnerabilities — GLSA 201710-12

Multiple vulnerabilities have been found in Puppet Agent, the worst of which could result in the execution of arbitrary code.

Affected Packages

app-admin/puppet-agent on all architectures
Affected versions < 1.7.1
Unaffected versions >= 1.7.1

Background

Puppet Agent contains Puppet’s main code and all of the dependencies needed to run it, including Facter, Hiera, and bundled versions of Ruby and OpenSSL.

Description

Multiple vulnerabilities have been discovered in Puppet Agent. Please review the references for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process or obtain sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All Puppet Agent users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/puppet-agent-1.7.1"
 

References

Release Date
October 13, 2017

Latest Revision
October 13, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries