Graphite: Multiple vulnerabilities — GLSA 201710-13

Multiple vulnerabilities have been found in Graphite, the worst of which could lead to the remote execution of arbitrary code.

Affected Packages

media-gfx/graphite2 on all architectures
Affected versions < 1.3.10
Unaffected versions >= 1.3.10

Background

Graphite is a “smart font” system developed specifically to handle the complexities of lesser-known languages of the world.

Description

Multiple vulnerabilities have been discovered in Graphite. Please review the referenced CVE identifiers for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or have other unspecified impacts.

Workaround

There is no known workaround at this time.

Resolution

All Graphite users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/graphite2-1.3.10"
 

References

Release Date
October 13, 2017

Latest Revision
October 13, 2017: 1

Severity
normal

Exploitable
remote

Bugzilla entries