hostapd and wpa_supplicant: Key Reinstallation (KRACK) attacks — GLSA 201711-03

A flaw was discovered in the 4-way handshake in hostapd and wpa_supplicant that allows attackers to conduct a Man in the Middle attack.

Affected Packages

net-wireless/hostapd on all architectures
Affected versions < 2.6-r1
Unaffected versions >= 2.6-r1
net-wireless/wpa_supplicant on all architectures
Affected versions < 2.6-r3
Unaffected versions >= 2.6-r3

Background

wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE 802.11i / RSN). hostapd is a user space daemon for access point and authentication servers.

Description

WiFi Protected Access (WPA and WPA2) and it’s associated technologies are all vulnerable to the KRACK attacks. Please review the referenced CVE identifiers for details.

Impact

An attacker can carry out the KRACK attacks on a wireless network in order to gain access to network clients. Once achieved, the attacker can potentially harvest confidential information (e.g. HTTP/HTTPS), inject malware, or perform a myriad of other attacks.

Workaround

There is no known workaround at this time.

Resolution

All hostapd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-wireless/hostapd-2.6-r1"
 

All wpa_supplicant users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=net-wireless/wpa_supplicant-2.6-r3"
 

References

Release Date
November 10, 2017

Latest Revision
November 10, 2017: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries