GNU Emacs: Command injection — GLSA 201801-07

A vulnerability has been found in Emacs which may allow for arbitrary command execution.

Affected Packages

app-editors/emacs on all architectures
Affected versions < 23.4-r16
< 24.5-r4
< 25.2-r1
Unaffected versions >= 23.4-r16
>= 24.5-r4
>= 25.2-r1

Background

GNU Emacs is a highly extensible and customizable text editor.

Description

A command injection flaw within the Emacs “enriched mode” handling has been discovered.

Impact

A remote attacker, by enticing a user to open a specially crafted file, could execute arbitrary commands with the privileges of process.

Workaround

There is no known workaround at this time.

Resolution

All GNU Emacs 23.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/emacs-23.4-r16:23"
 

All GNU Emacs 24.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/emacs-24.5-r4:24"
 

All GNU Emacs 25.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/emacs-25.2-r1:25"
 

References

Release Date
January 07, 2018

Latest Revision
January 08, 2018: 2

Severity
normal

Exploitable
remote

Bugzilla entries