Xen: Multiple vulnerabilities — GLSA 201810-06

Multiple vulnerabilities have been found in Xen, the worst of which could cause a Denial of Service condition.

Affected Packages

app-emulation/xen on all architectures
Affected versions < 4.10.1-r2
Unaffected versions >= 4.10.1-r2
app-emulation/xen-tools on all architectures
Affected versions < 4.10.1-r2
Unaffected versions >= 4.10.1-r2

Background

Xen is a bare-metal hypervisor.

Description

Multiple vulnerabilities have been discovered in Xen. Please review the referenced CVE identifiers for details.

Impact

A local attacker could cause a Denial of Service condition or disclose sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All Xen users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/xen-4.10.1-r2"
 

All Xen tools users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=app-emulation/xen-tools-4.10.1-r2"
 

References

Release Date
October 30, 2018

Latest Revision
October 30, 2018: 2

Severity
normal

Exploitable
local

Bugzilla entries