Tablib: Arbitrary command execution — GLSA 201811-18

A vulnerability in Tablib might allow remote attackers to execute arbitrary python commands.

Affected Packages

dev-python/tablib on all architectures
Affected versions < 0.12.1
Unaffected versions >= 0.12.1

Background

Tablib is an MIT Licensed format-agnostic tabular dataset library, written in Python. It allows you to import, export, and manipulate tabular data sets.

Description

A vulnerability was discovered in Tablib’s Databook loading functionality, due to improper input validation.

Impact

A remote attacker, by enticing the user to process a specially crafted Databook via YAML, could possibly execute arbitrary python commands with the privilege of the process.

Workaround

There is no known workaround at this time.

Resolution

All Tablib users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-python/tablib-0.12.1"
 

References

Release Date
November 27, 2018

Latest Revision
November 27, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries