spice-gtk: Remote code execution — GLSA 201811-20

A vulnerability in spice-gtk could allow an attacker to remotely execute arbitrary code.

Affected Packages

net-misc/spice-gtk on all architectures
Affected versions < 0.34
Unaffected versions >= 0.34

Background

spice-gtk is a set of GObject and Gtk objects for connecting to Spice servers and a client GUI.

Description

A vulnerability was found in spice-gtk client due to the incorrect use of integer types and missing overflow checks.

Impact

An attacker, by enticing the user to join a malicious server, could remotely execute arbitrary code or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All spice-gtk users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/spice-gtk-0.34"
 

References

Release Date
November 27, 2018

Latest Revision
November 27, 2018: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries