RPM: Multiple vulnerabilities — GLSA 201811-22

Multiple vulnerabilities have been found in RPM, the worst of which could allow a remote attacker to escalate privileges.

Affected Packages

app-arch/rpm on all architectures
Affected versions < 4.14.1
Unaffected versions >= 4.14.1

Background

The Red Hat Package Manager (RPM) is a command line driven package management system capable of installing, uninstalling, verifying, querying, and updating computer software packages.

Description

Multiple vulnerabilities have been discovered in RPM. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker, by enticing the user to process a specially crafted RPM file, could escalate privileges, execute arbitrary code, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All RPM users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-arch/rpm-4.14.1"
 

References

Release Date
November 28, 2018

Latest Revision
November 28, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries