ConnMan: Multiple vulnerabilities — GLSA 201812-02

Multiple vulnerabilities have been found in ConnMan, the worst of which could result in the remote execution of code.

Affected Packages

net-misc/connman on all architectures
Affected versions < 1.35-r1
Unaffected versions >= 1.35-r1

Background

ConnMan provides a daemon for managing Internet connections.

Description

Multiple vulnerabilities have been discovered in ConnMan. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker, via a crafted DNS packet, could remotely execute code or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All ConnMan users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/connman-1.35-r1"
 

References

Release Date
December 02, 2018

Latest Revision
December 02, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries