SpamAssassin: Multiple vulnerabilities — GLSA 201812-07

Multiple vulnerabilities have been found in SpamAssassin, the worst of which may lead to remote code execution.

Affected Packages

mail-filter/spamassassin on all architectures
Affected versions < 3.4.2-r2
Unaffected versions >= 3.4.2-r2

Background

SpamAssassin is an extensible email filter used to identify junk email.

Description

Multiple vulnerabilities have been discovered in SpamAssassin. Please review the referenced CVE identifiers for details.

Impact

A remote attacker could execute arbitrary code, escalate privileges, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All SpamAssassin users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=mail-filter/spamassassin-3.4.2-r2"
 

References

Release Date
December 15, 2018

Latest Revision
December 15, 2018: 1

Severity
normal

Exploitable
remote

Bugzilla entries