systemd: Multiple vulnerabilities — GLSA 201903-07

Multiple vulnerabilities have been found in systemd, the worst of which may allow execution of arbitrary code.

Affected Packages

sys-apps/systemd on all architectures
Affected versions < 239-r4
Unaffected versions >= 239-r4

Background

A system and service manager.

Description

Multiple vulnerabilities have been discovered in systemd. Please review the CVE identifiers referenced below for details.

Impact

An attacker could cause a Denial of Service condition or possibly execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All systemd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-apps/systemd-239-r4"
 

References

Release Date
March 10, 2019

Latest Revision
March 10, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries